Apple iPhones, iPads, and iPod Touch

To run the Ziik app on your Apple iPhone, iPad, or iPod Touch you will need to have installed iOS 9.0 or later on your device of choice. This means that if you have an... 

  • ... iPhone 4 or older.
  • ... iPod Touch (4th Gen. or older). 
  • ... original iPad. 

... you will not be able to use Ziik on your device. The reason behind this is that these devices and their predecessors cannot run iOS 9.0. The following models will be able to run Ziik:

  • iPhone 4S or newer.
  • iPod Touch (5th Gen or newer).
  • iPad 2 or newer.

Android Phones and Devices

If the smartphone or device you want to run Ziik on uses Android as its mobile operating system then it has to run on Android 5.0 or later. If it runs on an earlier version of Android you will, unfortunately, be unable to download and use Ziik on your device.

Did this answer your question?